madbeanpedals::forum

Projects => General Questions => Topic started by: Aentons on August 03, 2019, 02:18:44 PM

Title: "Warp" control blending issue
Post by: Aentons on August 03, 2019, 02:18:44 PM
So I've noticed that on some of the VFE pedals  that have the variable diode blending, that the effected signal seems like it sits behind some clean signal, or the signal does not always fully go thru one side or the other like it would when using a real switch.

I did some research and these seem to be what are refered to as a "Warp" control.
http://www.muzique.com/lab/warp.htm

This is how the VFE site explains it:
"Variable HCC circuitry allows you to fine tune the harmonics, compression, and clipping character of your tone."

In particular, the Red Horse has a seemingly always on clean signal and the distortion sort of sits behind/under it in the mix. The Scream will also not blend all the way over to the silicon diodes side of the pot(set the internal switch so th middle position uses LEDs and you will still see them light up)

Is this just inherent in the design of this type of blending, or are there different component values that could mitigate or correct it?

Title: Re: VFE Variable HCC blending
Post by: Aentons on August 10, 2019, 02:26:44 PM
By the way, I've had VFE production builds that exhibit this same behavior so I don't think it's just me. :)
Title: Re: "Warp" control blending issue
Post by: Aentons on August 12, 2019, 10:02:13 PM
Anyone?
Title: Re: "Warp" control blending issue
Post by: thesmokingman on August 13, 2019, 06:50:40 AM
ok ... feedback loop clipping will always pass some portion of the clean signal as well as the distorted signal. the more you hinder the signal (series resistance) going to the diodes, the less they have to clip. so unless your warp control is at either extreme, you're hitting a voltage divider before the diodes, path of least resistance wins. I'm with you in that I don't particularly care for warp controls.
Title: Re: "Warp" control blending issue
Post by: Boba7 on August 13, 2019, 07:43:21 AM
Yeah, Iíd rather have a simple toggle switch for clipping options.
But I think with a pot at min or max it shouldnt make any difference, compared to a switch
Title: Re: "Warp" control blending issue
Post by: Aentons on August 13, 2019, 06:10:14 PM
I think I've narrowed it down to the controls that have 3 clipping options rather than just two... the ones that have a clean middle option like the "Comp' control on the FRH and the SLA control on the Scream. It seems that the middle position is always on, even when the pot is turned to the extremes.

The Alpha Dog's Hard and Soft controls are good examples of a 2 option "warp" control that does not have the "sit behind" blending behavior.

I actually like having the "in between" blending options if they work correctly. So I'm looking to figure out what it is about the middle positions  that allows signal through when the pots are turned all the way.

The main difference in the stock TS and the VFE version is the drive pot value 500k vs1M and the resistor before/after at 51k vs 1k. Is it that 1k is too low to stop the bleed?
Title: Re: "Warp" control blending issue
Post by: WormBoy on August 14, 2019, 03:22:08 AM
The VFE control basically work like a 3-way switch, but with extra sounds 'in between'. Works that way in the Fiery Red, Alpha Dog and Scream. The middle position is 'no diode clipping' in that part of the circuit (my guess is that the values for the pots where selected to make the clipping threshold so high that it cannot be exceeded by the guitar signal). The Scream has the option (with the DIP switch) to make the middle position 'no diode clipping' or 'LED clipping'. Nice trick to provide a lot of different shades of clipping.

Not sure what you mean with "the "sit behind" blending behavior". But if you get that feeling with the clipping control in either extreme, or smack in the middle, I am pretty sure that you will get the same sounds when you would have used a switch; then it is part of the circuit and not related to the VFE clipping control.
Title: Re: "Warp" control blending issue
Post by: Aentons on August 14, 2019, 10:59:06 AM
Thanks for the replies folks! I think I understand how it should work, but what I am saying is that I don't think it is working as it should. Let me try to say it another way....

Set the middle position of the Scream SLA pot to use LED, then turn the pot fully counter clockwise to where it should only go thru the silicon diodes. Why do the LEDs still light up?
Title: Re: "Warp" control blending issue
Post by: WormBoy on August 14, 2019, 12:56:46 PM
I donít know, but I would not have predicted that. However, Iím pretty sure the same thing would happen in your build if you swapped the pot by a switch.