Author Topic: Ankh (Troubleshooting)  (Read 1534 times)

Droogie

  • Electron Doctor
  • *****
  • Posts: 659
  • Andrew
    • View Profile
Ankh (Troubleshooting)
« on: March 15, 2016, 09:32:07 AM »
I built the Ankh, but so far, it's not coming to life.  :)  What I get is fairly quiet, very gated distortion, and the gain pot kills the volume at all points below about 80% of max.

I checked values and orientation, and reflowed everything. The gain pot resistance measures low within the circuit so I may swap it out. I know that since the project is unverified, there are no existing voltage readings, but can anyone who has built a Rah or Prince Albert post voltages for the BS170s?
Chief Executive Officer in Charge of Burrito Redistribution at Hytone Electric

selfdestroyer

  • skilled electronics ninja master
  • Electron Doctor
  • *****
  • Posts: 4637
  • Cody - Fresno CA USA
    • View Profile
    • My Blog
Re: Ankh (Troubleshooting)
« Reply #1 on: March 15, 2016, 10:54:08 AM »
Here are mine from my Prince Albert I made a year or so ago.

BS170 Voltages
Q1 D= 5.8 G= 5.2 S= 3.7
Q2 D= 5.8 G= 5.2 S= 3.6
Q3 D= 5.8 G= 5.2 S= 3.7

Droogie

  • Electron Doctor
  • *****
  • Posts: 659
  • Andrew
    • View Profile
Re: Ankh (Troubleshooting)
« Reply #2 on: March 15, 2016, 11:19:50 AM »
Wow, that was fast! Thanks! I'll check it out after work.
Chief Executive Officer in Charge of Burrito Redistribution at Hytone Electric

selfdestroyer

  • skilled electronics ninja master
  • Electron Doctor
  • *****
  • Posts: 4637
  • Cody - Fresno CA USA
    • View Profile
    • My Blog
Re: Ankh (Troubleshooting)
« Reply #3 on: March 15, 2016, 12:06:02 PM »
Wow, that was fast! Thanks! I'll check it out after work.

I had them on my blog post when I built it.. Hope they help.

Edit:
Also, this effect loves higher output pickups. My strat sound like crap with this pedal but my Jazzmaster & SG love it! A boost is a great addition to this pedal.

I reboxed mine not long ago and added a boost to it.
http://music.codydeschenes.com/?p=2844

Cody
« Last Edit: March 15, 2016, 12:12:24 PM by selfdestroyer »

Droogie

  • Electron Doctor
  • *****
  • Posts: 659
  • Andrew
    • View Profile
Re: Ankh (Troubleshooting)
« Reply #4 on: March 15, 2016, 12:28:45 PM »
Good to know! I play a Tele w/trad output pups...
Chief Executive Officer in Charge of Burrito Redistribution at Hytone Electric

Droogie

  • Electron Doctor
  • *****
  • Posts: 659
  • Andrew
    • View Profile
Re: Ankh (Troubleshooting)
« Reply #5 on: March 15, 2016, 06:26:29 PM »
So my voltage on the drain of Q2 is 9.25; the others check out at 5.9. With some trepidation (actually a lot) is it at all possible that the connection of the positive side of C5 (10u) should go to the source of Q2 rather than the anode of D2. I'm not well versed in schematics/layouts, just noticed that the other FETs are connected in the same way on the layout and the schematic and the Q2 connection is different.
Chief Executive Officer in Charge of Burrito Redistribution at Hytone Electric

Droogie

  • Electron Doctor
  • *****
  • Posts: 659
  • Andrew
    • View Profile
Re: Ankh (Troubleshooting)
« Reply #6 on: March 21, 2016, 08:56:10 AM »
Update 3/21: After trying to troubleshoot this board, I pretty much gave up and reclaimed the pots to use again—at which point I noticed that the connection of lug 1 of the gain pot was, shall we say, not good. But, in the process of removing the pots, I dinged up the board pretty badly. Might be not worth repairing.

Long story short: my shoddy soldering means it's up to someone else to confirm. The connections to Q2 referenced in my last post are fine as-is. Everything checks out with the schemo, I just couldn't figure it out at first.
Chief Executive Officer in Charge of Burrito Redistribution at Hytone Electric

loreluc64

  • Diode Destroyer
  • *
  • Posts: 3
    • View Profile
Re: Ankh (Troubleshooting)
« Reply #7 on: January 25, 2018, 10:30:05 AM »
please see my other post, in my opinion there is a mistake in the schematic (47nF capacitor missing) which cause bad voltages on Q2 :

http://www.madbeanpedals.com/forum/index.php?topic=27311.msg264418#msg264418

best regards