Author Topic: Lifted pad Egodriver  (Read 1057 times)

Hyatt

  • Diode Destroyer
  • *
  • Posts: 23
    • View Profile
Lifted pad Egodriver
« on: October 07, 2010, 09:59:06 PM »
So I lifted the positive side of C10 on both sides of the Egodriver board somehow.  (was desoldering out 16v electrolytics to put in 25v). Is this board dead now or can I fix it somehow?  The whole board is populated, haven't done the wiring yet, this just happened now.  What should i do.  Thanks.   

chromesphere

  • Electron Doctor
  • *****
  • Posts: 2150
  • Paul
    • View Profile
    • Chromesphere
Re: Lifted pad Egodriver
« Reply #1 on: October 07, 2010, 10:08:44 PM »
Hi Hyatt,

I usually remove the old component, insert a new one and bend the lead over the remaining track (so the lead is parrellel with the track).  Cut the lead to size, and solder it directly onto the track.

Either that or you can drill a new hole through the track.  Might be difficult if its populated though.

Paul.
.                    
Pedal Parts Shop            Youtube

madbean

  • Administrator
  • Electron Doctor
  • *****
  • Posts: 8968
  • Brian
    • View Profile
    • madbeanpedals
Re: Lifted pad Egodriver
« Reply #2 on: October 07, 2010, 10:27:37 PM »
You can solder one in between the right-most lead of Q2 and pad3 of the Tone pot, or in parallel with R15 on the underside of the board. It's for filtering...the board will still work even without it.
I own madbeanpedals (duh). I am part owner of Function F(X).

Hyatt

  • Diode Destroyer
  • *
  • Posts: 23
    • View Profile
Re: Lifted pad Egodriver
« Reply #3 on: October 07, 2010, 11:50:17 PM »
Alright cool.  Glad its not lost.  Thanks for the help.  I'm going to wire it up and see if I should add the cap.  I left off R1 because the original doesn't have it, do you know if the original has the filter cap, Madbean?