madbeanpedals::forum

Projects => Tech Help - Projects Page => Topic started by: bamslam69 on February 07, 2020, 03:10:03 PM

Title: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 07, 2020, 03:10:03 PM
Hi everyone,
So I built this Madbean Cave Dweller back in 2016 and it had a fair bit of noise when I used a power supply. I ended up making Chromosphere's Power Pellet to reduce this, which it did nicely. I also made a quick 9V battery jack plug which worked too. No noise.
FFWD to yesterday. My wife gave me a Joyo JP05 rechargable power supply. Plug in the Cave Dweller and it gives out some mad power supply hissing when engaged. If I plug in another diy effect, Dead Astronaut's Tremshifter, no noise, so I'm sure I can scratch the supply as being the culprit.

Apart from hooking up the power pellet again, is there anything I should look at in the cavedweller circuit to reduce noise?
Thanks in advance!
Title: Re: madbean cavedweller - power supply noise?
Post by: jimilee on February 07, 2020, 03:58:49 PM
Lots of things really, got pics front and back along with voltages?
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 07, 2020, 04:28:15 PM
Thanks Jimilee,
I built it 3 years ago when I was just getting into this hobby. Happy to pull it apart and try to fault find it as itís a cool little delay.
I just tried it then, even when the supply is plugged in and switched off it makes a hum when turned on - when in bypass itís noise free.
Not totally discounting the power supply, but I think I should focus on my wiring first.
I think a plan is to pull it out of the enclosure and check for any shorts, but Iíll check out the project PDF if thereís volts shown there.
Mightíve answered my own question, but Iím all ears to any advice!
Cheers
Pete
Ps pics arenít working for me atm. Gimme a bit.
Title: Re: madbean cavedweller - power supply noise?
Post by: jimilee on February 07, 2020, 05:36:07 PM
Sounds good. I built several of those and kept one on my board. Definitely not a noisy pedal. Probably a loose connection. How are the input and out jacks. If it does it turned off, I would start there. And then test the switch with a DMM.


Sent from my iPhone using Tapatalk
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 08, 2020, 01:51:56 PM
Voltages below:
IC:
1- 4.96v
2- 2.489v
3- 0.0mV - (voltmeter bottomed out)
4- 0.0mV- (voltmeter bottomed out)
5- 2.939
6- 2.485
7- 0.611
8- 0.637
9- 2.493
10- 2.489
11- 2.490
12- 2.493
13- 2.493
14- 2.493
15- 2.493
16- 2.493
Q1
D- 6.99V
S- 0.451V
G- 0.1mV
REG
I- 9.28V
Gnd- 0.0
Out- 4.96V
Also worth noting that the lowest I could get the Voltage on the T1 trimpot was 6.99V.
 
Title: Re: madbean cavedweller - power supply noise?
Post by: jimilee on February 08, 2020, 02:01:59 PM
Have you tried a different pt2399 yet? They are a crapshoot sometimes. It may be time for an audio probe to see where the noise is introduced.
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 08, 2020, 02:27:01 PM
Cheers, I'll go through my parts bin and see what I can find, and have a play with my audioprobe.
Faultfinding is always fun. Off topic, I had an amp making weird noises occasionally when the reverb and chorus were engaged. It took a while before I realised the culprit was a dodgy power supply from some christmas lights on the same house circuit!
Anyway, I'll report back once I solve this. Still trying to post pics. I'm a bit slow on that front.

Title: Re: madbean cavedweller - power supply noise?
Post by: jimilee on February 08, 2020, 05:56:16 PM
The last place I lived, the power would surge at night and things would him when I tested them, very annoying. Hey, that clear light you have in that thing, whatís that for? If itís to reduce noise in the circuit, switch it to a green LED. That may be a source for the noise.


Sent from my iPhone using Tapatalk
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 08, 2020, 06:52:52 PM
Ah right, it could be one of those "super bright" LEDs from Tayda. I'll check it out.
It's absolutely pissing down here in Sydney (a nice break from the drought), so it's a good day to stay in and get productive.
Thanks heaps for the replies.
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 11, 2020, 05:50:05 AM
Problem solved. Just a dodgy solder on the footswitch.
Itís always something simple!
Thanks for the help Jimilee.
Title: Re: madbean cavedweller - power supply noise?
Post by: jimilee on February 11, 2020, 08:33:53 AM
Problem solved. Just a dodgy solder on the footswitch.
Itís always something simple!
Thanks for the help Jimilee.
Nice! Happy to help.


Sent from my iPhone using Tapatalk
Title: Re: madbean cavedweller - power supply noise?
Post by: bamslam69 on February 11, 2020, 09:31:07 PM
Wish I checked it properly before asking the question!

My fault finding regime now has, "poke and prod at my bad wiring & soldering" at Step 1.