Author Topic: Madbean libraries won't load into eagle  (Read 962 times)

mark123

  • Stompbox Star
  • ***
  • Posts: 152
  • I trusted the Autorouter
    • View Profile
    • Imagine Kitty Magazine
Madbean libraries won't load into eagle
« on: April 14, 2019, 07:10:43 AM »
My issue seems to be random. Sometimes I can use Madbean libraries in Eagle but sometimes I just cannot get them to work in a design. I'll add the libraries and they just don't show when I go to add a component.

This has only started happening since I updated to version 9.3. Before that it was fine. Is it just me? (I'm used to that. :D)

DLW

  • Solder Ninja
  • ****
  • Posts: 228
    • View Profile
Re: Madbean libraries won't load into eagle
« Reply #1 on: April 15, 2019, 05:54:08 AM »
i find myself continuously needing to click "use all" in the library of the control panel for it to show up. I'm using 9.3 as well.

m-Kresol

  • Electron Doctor
  • *****
  • Posts: 2774
  • Felix - Graz, Austria
    • View Profile
    • My blog - in german
Re: Madbean libraries won't load into eagle
« Reply #2 on: April 15, 2019, 09:03:25 AM »
i find myself continuously needing to click "use all" in the library of the control panel for it to show up. I'm using 9.3 as well.

Yep, you need to make sure that the dot next to the library is green for the library to be active. you can also click the dot instead of right click -> activate. Also, I disabled all the non-local libraries. There are just way too many and scrolling to the one you need is tedious, especially considering that the search function in eagle is still utterly useless.
I build pedals to hide my lousy playing.

My projects are labeled Quantum Effects. My shared OSH park projects: https://oshpark.com/profiles/m-Kresol
My build docs
My etching tutorial

mark123

  • Stompbox Star
  • ***
  • Posts: 152
  • I trusted the Autorouter
    • View Profile
    • Imagine Kitty Magazine
Re: Madbean libraries won't load into eagle
« Reply #3 on: December 07, 2019, 07:20:07 PM »
i find myself continuously needing to click "use all" in the library of the control panel for it to show up. I'm using 9.3 as well.
Sorry to come back to this but where do I find the "Use All"?  I'm not seeing it. Found it after posting. (Of course)
« Last Edit: December 07, 2019, 07:36:22 PM by mark123 »

mark123

  • Stompbox Star
  • ***
  • Posts: 152
  • I trusted the Autorouter
    • View Profile
    • Imagine Kitty Magazine
Re: Madbean libraries won't load into eagle
« Reply #4 on: December 07, 2019, 07:31:39 PM »
Yep, you need to make sure that the dot next to the library is green for the library to be active. you can also click the dot instead of right click -> activate. Also, I disabled all the non-local libraries. There are just way too many and scrolling to the one you need is tedious, especially considering that the search function in eagle is still utterly useless.
Found it. Thanks.
« Last Edit: December 07, 2019, 07:35:54 PM by mark123 »