Author Topic: Did I just blow up my Total Recall?  (Read 1472 times)

ckim715

  • Solder Ninja
  • ****
  • Posts: 266
    • View Profile
Did I just blow up my Total Recall?
« on: August 16, 2019, 07:25:10 AM »
So I had a faulty barrel plug on my Total Recall, so I swapped it out (wires are oriented correct, positive center). I plug in the PSU and turn it on, heard a loud pop, and now the pedal is dead. I checked the voltage on the EHX power supply, and I'm reading 33 volts DC. Could that have fried the board? If so, what are the likely components I'd have to replace? I'm assuming the LM7915, but is there anything else I should be looking hard at? I'm thinking maybe the 1N4751a as well, as it's only rated to 30v?
-Charlie

zgrav

  • Stompbox Star
  • ***
  • Posts: 195
    • View Profile
Re: Did I just blow up my Total Recall?
« Reply #1 on: August 16, 2019, 10:48:52 AM »
cross your fingers and see if it works after you replace the regulator. 

ckim715

  • Solder Ninja
  • ****
  • Posts: 266
    • View Profile
Re: Did I just blow up my Total Recall?
« Reply #2 on: August 22, 2019, 06:12:44 AM »
So I realized there was a solder bridge across the input and ground (1 and 2)  :-X

Really hoping that I didn't fry anything other than the LM7915.....
-Charlie

somnif

  • Electron Doctor
  • *****
  • Posts: 1683
    • View Profile
Re: Did I just blow up my Total Recall?
« Reply #3 on: August 22, 2019, 06:25:35 AM »
Can you take a picture of the guts?

Loud pops could be a few things. The regulator is one likely candidate, but that 240R resistor also could've been cooked (33V across 240 ohms = 4.5 Watts).

Take a picture or two, and if its handy, poke around with your multimeter, see if parts on the power rail still behave as they should.

ckim715

  • Solder Ninja
  • ****
  • Posts: 266
    • View Profile
Re: Did I just blow up my Total Recall?
« Reply #4 on: August 22, 2019, 08:16:38 AM »
Will do when I get home. Reg is DEFINITELY cooked though.
-Charlie

ckim715

  • Solder Ninja
  • ****
  • Posts: 266
    • View Profile
Re: Did I just blow up my Total Recall?
« Reply #5 on: August 26, 2019, 07:50:40 AM »
It was just the regulator. Many many many thanks to tcpoint for sending me one! We are back up and running.
-Charlie