Author Topic: Sea Urchin feedback not working...  (Read 1854 times)

Willybomb

  • Electron Doctor
  • *****
  • Posts: 1590
  • Willy, not really a bomb.
    • View Profile
    • RockStarGuitar
Re: Sea Urchin feedback not working...
« Reply #15 on: July 19, 2020, 04:10:06 AM »
I'm just following this because I had a run of one repeat PT based delays, usually the smaller ones.

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #16 on: August 01, 2020, 10:12:09 AM »
I've taken a break on the sea urchin as I was close to finishing another board, which of course if giving me problems. Grrrrrrrrr

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #17 on: April 20, 2021, 08:47:35 PM »
Howdy folks,
Got back to the urchin, it works! It works too much! With the feedback pot turned all the way counter clockwise, now I get lot's of repeats, too many!
Any help is appreciated..
thanks

jimilee

  • Global Moderator
  • Electron Doctor
  • *****
  • Posts: 9371
  • Jimi Lee
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #18 on: April 21, 2021, 06:54:07 AM »
You mean it oscillates?


Sent from my iPhone using Tapatalk
Pedal building is like the opposite of sex.  All the fun stuff happens before you get in the box.

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #19 on: April 21, 2021, 11:05:04 AM »
Well not exactly. When the feedback knob is fully counter clockwise, I get like 10-15 repeats. If I turn it up, it self oscillates at about 1/3rd of the way up...

jimilee

  • Global Moderator
  • Electron Doctor
  • *****
  • Posts: 9371
  • Jimi Lee
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #20 on: April 21, 2021, 11:06:17 AM »
Have you checked you resistor values yet?


Sent from my iPhone using Tapatalk
Pedal building is like the opposite of sex.  All the fun stuff happens before you get in the box.

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #21 on: April 21, 2021, 03:39:39 PM »
good point. I'll get back to you

madbean

  • Administrator
  • Electron Doctor
  • *****
  • Posts: 9964
  • Brian
    • View Profile
    • madbeanpedals
Re: Sea Urchin feedback not working...
« Reply #22 on: April 21, 2021, 06:11:15 PM »
Well not exactly. When the feedback knob is fully counter clockwise, I get like 10-15 repeats. If I turn it up, it self oscillates at about 1/3rd of the way up...

You should only have one repeat full CCW. Something has gone wrong! Possibly lug1 of your Feedback pot is not properly connecting to ground.
The resistor that controls the self-oscillation point is R14 (5k1) and can easily be bumped up to 12k.

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #23 on: April 22, 2021, 06:14:26 AM »
OK - that's good advice too. The resistors check out. I'll look at the ground on that pot too.
thank you!

pgodfrin

  • Transistor Tickler
  • **
  • Posts: 101
    • View Profile
Re: Sea Urchin feedback not working...
« Reply #24 on: April 24, 2021, 08:48:35 AM »
Thanks for the help folks. In the end, the B50K pot was bad. Replaced that and we're good to go!
woohoo!