Forum may be experiencing issues.

Main Menu

Headtrip 2 missing voltage on eprom [Solved]

Started by Sarsipius, February 06, 2024, 08:44:33 PM

Previous topic - Next topic


completed my headtrip 2 build and it no workie.  dry pot works and can hear a pop when changing patches.  No effect tho.  Wet pot turned all the way up.  Voltage are all correct except pins 5 and 6 on the eprom read 0.  Pin 14 and 15 on the FV-1 are both 3.3vdc but 5 and 6 on the eprom are 0.  The pads for pins 5 and 6 on the eprom read 0 as well.  According to the schematic they should match pin 14 and 15 on the FV-1 and there is nothing between the FV-1 pins 14 and 15 and eprom pins 5 and 6.  Checked for continuity between 15 and 5 and between 14 and 6 and it reads good.  Where did the voltage go?

One additional note.  The volume of the popping when changing patches is controllable via the wet pot (the wet pot seems to be working but no effects.)

update:  tracing the signal and found it dropping out at R4.  R4 reads 10k.  Not sure why signal is lost there.  it's on one side but not on the other.

with the tails switch on the signal is present at pin 1 and 2 of the FV-1 but not on 28 or 27.  It's not coming out of the FV-1.


Are you sure you have 3.3v at pin8 or the EEPROM? I don't know how you would not have matching voltages from pins 14 and 15 to pins 6 and 5 since you have continuity.

It's normal not to hear you audio at R4 (where it connects to inverted pin2 of IC1). As long as you have audio out of pin1 of IC1 then you are fine.

Does your EEPROM have a grey or gold mark on the top of it? I mark them all after I program them.


It is marked.  Grey I think.  I'll double check everything again tomorrow.


So here is what happened:

The pins 14 and 15 on the FV-1 did not have connection to their pads.  When Checking voltage on those pins, the lead pressed the pin down to the pad and i could read voltage.  Then when moving over to the EEPROM (removing the lead from pin 14 or 15 of the FV-1) the voltage wasn't present on pin 5 or 6 (because the connection was now broken when the pins of the FV-1 lifted ever so slightly off the pad).  Of course, then when checking continuity, i was pressing the pins of the FV-1 back to the pad and i had continuity. 

Feels stupid to have missed this but I guess some times all you need is a good nights sleep and a cup of coffee.  Anyway.  The pedal works now. 

One thing tho,  patch 7 and 8 are the same, no changes between the two.  This makes sense based on the schematic however the description shows 2 different reverb effects.  On mine both patch 7 and 8 seem to be "these ruins".  Other than that everything works great!  Cool pedal.  I've built 12 of your pedals and they are all great.  I built the protorig just before this one and it was very helpful in figuring out what was wrong.  I highly recomend it to anyone who builds more than 1 or 2.  Thanks for your help!  Now to get started on the Archibald!


Yeah, I had thought after the fact that there may not have been good solder connections on those pins. I'm glad you got it sorted.

I'm concerned about what you said about the patches though. I'll check back on my HEX file to see if anything changed. I don't recall ever doing that but it's easy enough to program an extra EEPROM and pop it in my build. When did you order the HT2?


It was March 24th, 2023.  It's taken me a minute to get around to building it.  Built a couple of amps last year instead.