Author Topic: Help, Dirtbag VC Pads broke (Problem Solved!!)  (Read 976 times)

monkeyssj1

  • Solder Ninja
  • ****
  • Posts: 279
  • daniel
    • View Profile
Help, Dirtbag VC Pads broke (Problem Solved!!)
« on: January 21, 2013, 02:46:50 AM »
So I was biasing my d-bag and it was sounding amazing. It has MN3005s so I mounted the roadrage to the bottom of the enclosure. While I was doing some finishing turns on the trimpots, the wires attached to the VC were ripped out. I tried to remove the excess wire from the pads and I wasn't careful enough and both pads were seriously damaged. I was able to solder both wires "onto" where the pads were with what was left of them...the 15v pad in this case has the wire now only connected to the bottom of the pcb, and the ground wire is only connected to the top. None of the pots work except volume which now acts backwards (turn it left and volume increases, right and it goes away). I checked continuity and it seems to check okay for both pads.. it also seems 15v is running through the 15v pad... I'll check again tomorrow morning.


Any help would be hugely appreciated. It'll be pretty sad if this pedal is doomed :'(
« Last Edit: January 21, 2013, 07:38:57 PM by monkeyssj1 »

LaceSensor

  • Electron Doctor
  • *****
  • Posts: 3012
  • Lovetone 4 Ever
    • View Profile
    • How Not To Make A Pedal
Re: Help, Dirtbag VC Pads broke
« Reply #1 on: January 21, 2013, 03:10:54 AM »
just trace the next components on the PCB that the pads link to, and directly solder the wires to those components (with the help of the schematic in the build doc )


monkeyssj1

  • Solder Ninja
  • ****
  • Posts: 279
  • daniel
    • View Profile
Re: Help, Dirtbag VC Pads broke
« Reply #2 on: January 21, 2013, 10:23:26 AM »
I'm a very new at reading schematics.. it seems like VC is connected to 4 points on the board?

LaceSensor

  • Electron Doctor
  • *****
  • Posts: 3012
  • Lovetone 4 Ever
    • View Profile
    • How Not To Make A Pedal
Re: Help, Dirtbag VC Pads broke
« Reply #3 on: January 21, 2013, 10:57:35 AM »
yeah just connect it to any of those points. assuming the traces going from the VC pad to all these other points are intact, it will solve the issue of having fucked up the actual VC (15v) pad.

if for some reason your mashing of the VC pad has also damaged the traces, you might need to solder the 15v VC wire to multiple points. However, you can easily check for continuity.

hope that makes sense and helps
im sure someone will chime in if i am talking nonesense

monkeyssj1

  • Solder Ninja
  • ****
  • Posts: 279
  • daniel
    • View Profile
Re: Help, Dirtbag VC Pads broke
« Reply #4 on: January 21, 2013, 11:21:33 AM »
Thanks for the advice. Ill check when im home

monkeyssj1

  • Solder Ninja
  • ****
  • Posts: 279
  • daniel
    • View Profile
Re: Help, Dirtbag VC Pads broke (Problem Solved!!)
« Reply #5 on: January 21, 2013, 07:40:01 PM »
Success, soldered some thin wire to what was left on the pad to the actual trace and it works beautifully again! Thanks for the quick help Lace  :)

LaceSensor

  • Electron Doctor
  • *****
  • Posts: 3012
  • Lovetone 4 Ever
    • View Profile
    • How Not To Make A Pedal
Re: Help, Dirtbag VC Pads broke (Problem Solved!!)
« Reply #6 on: January 22, 2013, 08:44:17 AM »
welcome