News:

Forum may be experiencing issues.

Main Menu

Archibald 2022 Volume issue FIXED

Started by UncleLarry, November 29, 2022, 09:30:39 PM

Previous topic - Next topic

UncleLarry

Just finished the Archibald '22 build. Sounds amazing except when I switch from EQ to HI/LO mode there is a huge volume drop. Even when the level is at max I can only get about 3/4 perceived unity gain in that mode. EQ side has plenty of output. I've already checked all the component values and such. Any hints on where else I should start checking?

FYI - I saw the thread regarding a bad J201 possibly causing issues. I have a batch of 20+ year old NOS and 2N5457 that I could swap but just wanted to see if the brain collaborative had any other ideas before I do so.

jimilee

Could literally be anything. I'd have to audio probe.


Sent from my iPhone using Tapatalk
Pedal building is like the opposite of sex.  All the fun stuff happens before you get in the box.

EBK

A guess: Check to see if your switch is shorting the two tone control subcurcuits (EQ and HI-LO) together (perhaps due to a solder blob hidden by the board.
"There is a pestilence upon this land. Nothing is sacred. Even those who arrange and design shrubberies are under considerable economic stress in this period in history." --Roger the Shrubber

UncleLarry

#3
So, I discovered that the pedal is sensitive to different types of tubes. The Chinese 12ax7 that I was using wasn't allowing enough gain to get the pedal above unity in HI/LO mode. When I swapped it for a Russian version, there is a significant gain boost from both sides of the EQ and the issue is fixed.  :)

EBK

Interesting.  Glad you got it sorted out.
"There is a pestilence upon this land. Nothing is sacred. Even those who arrange and design shrubberies are under considerable economic stress in this period in history." --Roger the Shrubber

UncleLarry

#5
Quote from: EBK on December 02, 2022, 11:16:25 AM
Interesting.  Glad you got it sorted out.

Yes, me too! I thought I was losing it because I couldn't find anything physically wrong with the build.

I did some more experimenting and tried a couple of late '90's Yugoslavian Ei brand and an unknown brand of old stock tube that has "Britain 12AX7A/ECC83" stamped on it. Both are longer plate tubes similar to the old German Telefunkens. Huge volume boost with these.

There's something about how the circuit is designed that favors certain tube types. The Russian one that is commonly available and worked well is an EHX 12AX7EH that has the short dual parallel plates. I settled on the old stock "Britain" tube because it provided the most output; about 20%-ish more than the EHX. The Ei tubes were good as well, but I liked the sound of the Britain tube better.

I'm curious to find out what tubes are used in the actual B.K Butler pedals. I wonder if anyone in the forum has one that they could open and find out? 

dc001013

According Kit Rae's Tube Driver page the earlier were known to use long smooth plate EI's often rebranded for bk butler or chandler. In 2006 he switched to the Beijing "Golden Dragons" with just BK written on them. I assume he's referring to the square foil getters Chinese tubes that were made in Beijing. Not sure what he uses now.

At the moment I'm using a NOS RCA tall black plate 5963 which is a 12au7 varient. They can be had at a bargain. I use it to tame the gain but it still gets suprisingly heavy.